Coolant leaking from fuel injector?

I have an 86 300SDL and yesterday spotted a small pool pf coolant when i returned to the car. I looked underneath and could not find a leak and when i got it up on ramps later i found the coolant was
dropping off the transmission. Fairly confused, i followed it back and finally found it running between the injection pump and block and a puddle around the #3 injector and nowhere else. Serious problem? Also, when looing between the injection pump and block i could see attached to the pump is a lever with a spring on one side running towards the rear of the car and a head on the other end of this lever, sametype as the accelorator linkage uses to pop on connectors. But there is nothing attached to this head. Is there something missing? I could not find rods in there not connected. I can't imagine putting a connection point with a spring return on something that doesn't connect to something else. Thanks for any info, Shannon 86 300SDL 376K miles and still 27mpg hwy :-) 80 450SL 221k mi.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You definitely have a leak in heater hoses... change them out. Don't forget the heater hoses in between your two firewalls.
As for injection pump... not sure.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.