Cooling system bleeding in 300E

One spot is the thermostat, but there has to be another place because it "blurps" when I start the car and the heat is worse than before =/.

--
There are only 10 types of people in the world, those who understand binary
and those who don't
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

    there is a plug (mine is red) at the bottom of the radiator. I believe it was the left side looking at car.
regards
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
TEMP sending unit? unscrew it if it is on the top or close to the top of the motor. air could be trapped up around the head.
motor OFF !
case
the case, minus a few cans!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I think the blurping is from the heating element in the car. But I'll try the temp sensor to. Tnx
meddelandet

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I was more after getting air OUT of the system, but thanks anyway ;)
(Sorry 'bout the mail.....)
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.