intermitant fault on 300sl 1989

can any one help? i have a 1989 300sl which starts and runs for 1 or 2 seconds,then cuts out.the problem seems to be no power to the fuel pump . if power is applied directly to fuel pump then there is no
problem.this is an intermitant problem and is driving me nuts! i live in zimbabwe and can not find a mechanic to help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The fuel pump is powered by a relay - a switch. Relays get "tired" and after 16 or 17 years it's time for your relay to become intermittent.
So a "fuel pump relay" is what's needed, IMHO.
For future reference, there's also an "over voltage protection relay" which creates strange engine behavior when it fails. It has a fuse on its top.
Hope this solves the car's problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
T.G. Lambach wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i forgot to mention that i do not have a manual that is very explicit.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
lynne wrote:

Hm,
don't know if this applies to you:
http://www.benzworld.org/forums/r129-sl-class/1255861-90-300sl-fuel-pump-relay-location.html
ws
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
thanks ws.but the 300sl i have is a 1989 which is the last of the old models.but an interesting site .will keep trying to find it! lynne
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.