2005 x3 Climate Control Issues

I have a 2005 X3 with automatic climate control. I can't seem to get the heat to work correctly. The A/C works fine but now that it's getting cold, I
need heat. (I bought it used and this is the first winter I've had it.)
If I leave the auto control on, and turn off the a/c button, all I get is cold air coming out of the center section. I try raising the auto temp but it does no good. If I switch to manual air flow, I can get warm air to come out of the floor section and window section, but the center console still blows cold air. I close the air recirculation so only the cabin air is being heated. The A/C button is off.
Is there anything I'm doing wrong or any suggestions on how to get it to work correctly. And, if in the manual mode I switch on the front window defroster, it shuts off all other air flow.
TIA
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It should give the cabin temperature that is set regardless of AC on or off. Sounds like the unit is faulty. Does the outside air temperature indicator read correctly? This has an effect on the interior heater.

This is correct operation - the entire heater output on max is directed to the screen to defrost it as quickly as possible.
--
*How about "never"? Is "never" good for you?

Dave Plowman snipped-for-privacy@davenoise.co.uk London SW
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

I don't know if the X3 is the same, but on my 5 there's a thumbwheel in between the two center vents that controls the air temperature from those vents separately from the rest of the car. If that thumbwheel was set all the way down to its coldest setting, I'd have exactly the conditions you are describing.
--
Dan.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

That's what I thought too. It should be obvious, but blue is cold, red is hot.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.