Trunk latch and windshield wipers

I've got a 2003 Focus ZTS, and I've developed a couple of problems. I was just wondering if anyone else had the same issues. I've
fortunately got a few months left on the warranty, so getting them fixed shouldn't be a problem, but I'm curious just the same.
First, the trunk latch stopped working quite right. Sometimes it wouldn't open up all the way. You could open the trunk, but you couldn't close it again unless you "helped" the latch to open the rest of the way. Now it can't open on its own either. Now I have to pull the trunk open while pushing the trunk button on the remote in order to get it open. I suppose the key would work too, but the principal is the same.
The second problem is with the windshield wipers. They don't always return to their starting position. This is most evident when the windshield is somewhat dry, like when it has just started raining, or I'm just trying to clear condensation. If I push the lever down to get one "wipe", the wipers stop when I let go. The do the same thing if I move the lever up one notch and then turn them back off mid-cycle. I've started turning the interval setting up, and then putting the lever in the first position, waiting for the cycle to end, and then turning them back off.
Are there any other common problems people have had, so I can have them looked into as well before the warranty ends?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Re Trunk latch and windshield wipers:

On my '05 I had the same problem. I don't know if your model is built the same, but open the trunk and look for two small black rubber bumpers shaped like a large pacifier nipple. The are about the size of a thumb but about 3/4" in diameter at the base and about an inch or so long. They are attached to the underside of the inside lip of the trunk lid. They rest on the black plastic of the trunk opening when the trunk lid is closed. They can screw in and out. Screw then out a turn and see if that help.
--
To email me directly, remove CLUTTER.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

My focus had the same problem with the windshield wipers - I mentioned it to the Ford dealers when I had the car serviced and they knew immediately what the problem was! - 2 relays replaced at a cost of around 6 GB pounds fixed it...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.