97 ZJ Electrical Problem

Power windows and power locks don't respond to any of the door controls on any door. Locks do lock and unlock with the remote. Power mirror on drive
r's door doesn't work (the one on the passenger door doesn't either but it' s disconnected so I don't know for sure if it's part of the problem, and as to why it's disconnected, don't get a replacement off of ebay--the connect or was wrong and I haven't had time to replace it). Instrument lights and readouts on overhead console dim and brighten periodically, often after a b ump. Whacking the panel near the light switch usually brings the brightnes s up until the next bump. The driver door has been removed and replaced a couple of times but the connector seems tight.
Before I start tearing things apart I figured I'd see if this rang any bell s with anybody. I'm hoping I'm looking at one problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
J. Clarke wrote:

You don't specify what you're driving, but this sounds like checking the ground straps would be the first step. Run a jumper cable from the battery negative to a clean metal spot on the firewall and see how that affects the problem.
--
Will Honea


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Will Honea wrote:

From the 93 perspective I'd say grounding or harness, but heep started using body control modules past 95. At that point it stopped being an easy fix. :(
--
DougW



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Thursday, July 31, 2014 11:49:11 PM UTC-4, DougW wrote:

Well, found windows/locks problem. People who replaced the window glass di dn't seat the connector tight (note--that also kills the courtesy light in the driver's door--not sure about the passenger door.. Meanwhile, found ou t why the radio sounds like crap--the foam on the speakers is gone. Still haven't sorted the instrument lights, but it's nice to be able to open a wi ndow.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.