2000 Kia Sephia Idle's Rough and sluggish accelleration

Hello all,
I am by no means a "car guy". By that I mean, I can do minor repairs but I wouldn't know where to begin to overhaul the engine. I have a
2000 kia sephia with close to 150k miles on it. Yesterday I noticed it runs sluggish when accelerating and started idling rough.
Before I take it to a mechanic, I was wondering if there was some things I could try myself to correct this issue.
Thanks, GuyInTn
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Try some car/fuel injector spray. Had doubts it would help but a guy in work swore by it , he sprayed some in the intake with the air filter out ... worked very well .
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i'm a kia tech has timing belt been changed if not it could have sliped a tooth or 2 is check engine light on ? and the other cause coule be cloged cat converters

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Apr 20, 1:58 am, DrGuRu <> wrote:

A slipped timing belt? That's a good one. If it slips more than a tooth you'll have a lot more than sluggish performance to worry over.
To the original poster: Your symptoms could have a multitude of causes. Do you have an illuminated check engine light while driving? Any work done recently?
Generally speaking, a rough idle starting all at once without ANY prior symptoms sounds like an ignition problem to me, with the plug wires being the first thing I would check.
Chris
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Change your spark plugs!! I have a 2003 Rio, and one day it just went from running perfectly to barely stumbling along. I put in a new set of plugs, and it runs like new. With just 122000 klms on it, (about 77000 miles)I can't figure out why. The plugs I took out don't look bad at all, but don't look a gift KIA in the grill. HA-HA!
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.kia / More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.