Disco 3.5 overheating

Hi chaps. Anybody any experience of occasional overheating causing water loss. Temp gauge NEVER moves much above 1/4 so suspect thermostat/sender is up the
duff, no other signs of fault anywhere - no water in oil, engine runs clean (no smoke or steam). It usually happens when engine is under load for a time - Towing or climbing gradients fully loaded. Vehicle is 1993 Disco 3.5 V8i All help appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@ntlworld.com "James Taylor" wrote:

You're right to consider the sender, but there's likely something not quite right. The radiator may well not be passing air or water as freely as it should. It may be a problem with the fan. Depending on the fan-drive, there might also be a water-pump problem, but that depends on the engine design and layout, and I only throw it in as a general possibility.
--
David G. Bell -- SF Fan, Filker, and Punslinger.

"History shows that the Singularity started when Sir Tim Berners-Lee
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
James Taylor wrote:

Land Rover Owner Internaional May issue ( no connection ) has a very good write up on the mighty V8, and some very good diagnostic advice... though it talks about the 3.9. 4.2 upawrds the symptoms you describe seem to point to a possible cracked liner.
n
--

No forbidding allowed

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.