1989 300E

guys, please help!!!!!!!!!!!!!!!! I had a blown fuse in the above car and when i replaced it the horn was continously humming. I do not know what the hell is going on. Also i have realised the central locking
system and the antenna are no longer functioning. The antenna does not go down and i have go around opening and closing the doors. I will appreciate your help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
First of all would check whether other fuses are blown, particularly the fuses for antenna and central locking.
Otherwise it may very well be a loose connection in a common ground point.
Start with one of the things that do not work, the central locking for instance, and measure if it gets 12 volt supply to the unit. If not, trace towards the fuse. Or rather trace in the fuse box, since the problem apparrently is in a common place.
If you do have 12 volts supply, mesure the voltage at the ground connection of the unit. That should be 0 volts. If not, trace towards the grounding point.
Find a good chassis point as reference for the measurements.
Good luck.
/Jens
Mo wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Humming horn means that possibly your horn ring at the steering wheel is faulty.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.