1990 Nissan Pickup / Engine Rattling At Startup

Hello. I've got a 1990 Nissan Pickup 2WD with a 1989 2.4 liter 4 cylinder 2400 12 Valve Engine. Everytime I crank the vehicle, whether
it be hot or cold, it seems to rattle for about 6 or 7 seconds until the oil light goes out. After that the engine runs smoothly with no problems whatsoever. I recently changed the oil pump and it helped reduce the problem slightly. I've been trying to figure out what the problem is. I've changed the oil and put heavier grade oils in it. I was using Castrol Synthetic 20W-50 until I replaced the oil pump and now I'm using Castrol GTX 20W-50. I've also been using a Fram oil filter everytime I've replaced the oil. I've had no other problems out of the truck other than that rattling when I crank it up. Usually when it's only been sitting for about 30 minutes or so it cranks up with no rattling, but if it sits for 2 or more hours it has the problem. I've been told to try these methods: Replace PCV Valve Replace Lifters Add Slick 50 my next oil change Remove the oil pan and change the oil pickup tube Add Engine Restore Replace the Head
Of course I want to try the easiest (and cheapest due to being a college student living on campus) way to fix my engine because I know that rattling sound over time can probably become an even worse problem than it already is. I've had people tell me that it's normal for it to make that sound. I find it very hard to believe that it's normal.
Thank you very much to anyone who responds, Matthew
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@hotmail.com wrote:

How many miles on it?Did it have the timing chain guides replaced? A known problem on early ka24e engines.regards.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Since I replaced the engine after fully rebuilding it I've put at least 33,000 miles on it. I did have a chance to replace the chain guides because a friend explained to me that the KA24 engines had problems with those as well.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@hotmail.com wrote:

Sounds like lifters which are hydraulic and in the rocker arms.They are very small. I get this too in my 91 pu, but only if I let it sit for weeks. I got 199k miles on the original engine.Purchase it with 150k miles and did the timing chain upgrade.I am using mobile 1 syntho now and don't get the noise.You shouldn't be getting the noise from overnight sitting and heavy weight oil as you are using.If you do then I'd say the lifters.With syntho oil I get 25-29 mpg.The dino heavy cuts this down a few mpg.regards.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.