98 Altima erratic shifting


My car has developed an intermitent pb related to shifting (auto tranny). Sometimes the gearbox is locked on the first gear. If it turn it off/on it disapears. I also have sometimes the overdrive light that flashes at turn on. I have the check engine light on, i have to check the codes in the ECU. Odometer, speedometer are OK.
Any ideas (speedometer head ?)?
Thanks
LD
Reply to
luc.destombe

so the codes are : 7 - 5 : EVAP Control System 11 - 2 : Revolution Sensor (i got the codes meaning here
formatting link
Does that speaks more to you ?
Thank's, LD.
Reply to
luc.destombe

Well... that's interesting. It occurs to me that the shifting might get confused if the ECU receives erratic/erroneous information regarding vehicle road speed. This could certainly tie in with your 1102 code.
formatting link

Reply to
Telstar Electronics

Hello,
should i replace the speedometer head, or the other sensor in the tranny ? Or check for bad connector ? Or bad wire ?
What do you advice me to do ?
Thank's, LD
Reply to
luc.destombe

Back from week end,
I continued my investigations. After reseting the error codes it took 2 days to appear again. It was at the supermarket with the engine hot. It was locked on the 1st gear, it starts ok and then stays on the first gear, no second gear. After stopping the car, and retarting the engine everything was ok.
I have to check if it is the same code, will do this this week.
It did the same thing this afternoon after have driven 1.5h on the highway when i went out at the first redlight it did the same issue, it never occurs while i'm driving.
I never lost transmission.
I will buy the haynes manual this week and start to try to fix it.
Thank you guys for your help, Br, LD.
Reply to
luc.destombe

MotorsForum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.