Pontiac Trans Sport 1994 - Major Electrical Problem

I have a 1994 Pontiac Trans Sport that is having strange electrical issues. I went to turn the engine over and the gauges started going crazy and strange
beeps from the chime module then nothing. Battery level is fine, all fuses check out. I do have an inverter wired in to the glovebox lighting wiring which is smaller gauge wire than it should be. I took the panel off underneath and noticed some overheated/scorched wiring leading to the middle (white) connector going to the engine control computer. Have I fried the computer or what to do? -stuck in Colorado
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Thu, 12 Mar 2015 22:18:00 +0000, Mitch

First thing - check the engine ground. My 1995 TransSport did that one day and I found a broken ground wire between the engine and the rad frame.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
replying to clare , Mitch wrote:

will do, what does this look like- where is the easiest place to access and check it? underneath the vehicle? between engine and radiator? .. will go look right now thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
replying to clare , Mitch wrote:

Turns out it was the smaller ground cable. Now it runs but seems to still be having issues- feels like it is missing on acceleration like something is still not right with the computer. Going to investigate further, thanks for your help!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Mon, 16 Mar 2015 23:18:00 +0000, Mitch

I never did get my '95 working like I thought it should. Had a Delco rebuild engine in it and I couldn't pull my 17 foot camper more than 30 miles without throwing the CEL. My 3 liter Aerostar pulled it effortlessly. It seemed to be hard on O2 sensors too - went through 3 in ender 100,000km. (that's as far as the rebuilt engine lasted).
Basically you have to remember you are driving a GM. Garbage Machine. Won't own another one unless it's given to me!!!. My last good GM was my '28 Chevy National -and it was pretty rough!!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.