power mirror question

Hi all,
One of my power side mirrors (900S, 1992) is having a slight problem: it works fine moving left, right, or down, but it won't tilt up. It makes a noise like
it's trying to though. I'm guessing that something probably just needs to be lubricated in there, but I'm not sure how to get into the mirror housing to investigate. Bentley doesn't seem to cover the power mirrors for some reason. Any ideas?
Thanks, John
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

works
like
be
to
reason.
It's my experience that the connectors to the mirror get bad connections. Including the heated mirror thing. (the mirror is a pain to fix. involves using that stuff for fixing the rear window defroster.) The Bentley book has a pretty good section, I thought, on the power mirror thing. The problem for me was a bad connection on the connector in the mirror housing itself. Pull the door panel off, remove the mirror from the door. Use a 9 volt battery to check which connection is faulty. (that's the easy way)
Good Luck, dave
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Ah, I was looking in the wrong section. I see it now. I'll check your suggstions.
Thanks, John
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.