'92 V6 won't accelerate

(Automatic tranny, 187K mi)
Pressing pedal to the floor (at any speed from idle to midrange) causes car to slow down! (From idle, it will accelerate for a split second, then slow,
then accelerate, then slow ... all the while with the pedal to the floor.) If I back off the pedal a bit the car will accelerate moderately, as it should. Usually.
Any attempt to pass on the highway becomes an embarrassing no-go. "Harry, why does that car behind us keep pulling out to pass only to pull in behind again?"
Even accelerating up a moderate hill at highway speed will usually result in the car stumbling, bogging down until I ease off on the throttle. On my last trip out of town I could drive a maximum of only 60mph. When I tried for more: stumble, bog, slow-down ... and very foul-smelling exhaust.
FWIW, symptoms seem to occur only after an extended drive.
TIA, Puzzled in the slow lane.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Does is run ok till its warmed up, it sounds like a transmission
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Sounds like intermittent fuel starvation. At 187K your fuel filter could be clogged. Could also be a failing fuel pump. I'd replace the filter first before you dig into the pricey repairs. Easy enough to do it yourself. FWIW
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'll try the fuel filter first, thanks.
wrote:

car
slow,
floor.)
in
in
last
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the hose between the MAF-sensor and the throttle-body for leaks. Because the engine twists a little under load, when you accelerate or drive up hill, a small rift would widen out and cause false air fooling the ECU. When accelerating in reverse the engine twists in the oposite direction "closing" the hole.
Leon

car
slow,
in
in
last
--
Utgende melding kontrollert og funnet fri for virus
Checked by AVG anti-virus system (http://www.grisoft.com ).
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The clue about the exhaust smelling bad, might be telling you your catalytic(spelling?) converter may be blocked.
Just my 2 cents
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.