1994 dodge intrepid 3.3l

the car runs great for a minute or two then it will drop into granny gear and wont shift then when you shuit it off it will be fine until you drivwe it for a minute or two then it will again drop into granny gear
anyone have any idea what is wrong and how i might fix it
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
bignbad79 wrote:

The transmission is going to "limp-in" mode which is second gear, because its computer thinks there is something wrong with it. Maybe the clutches are worn, maybe there is a bad clutch seal, maybe bad hydraulics, maybe a bad input or output sensor. The only right way is to have the transmission scanned for fault codes, then a proper diagnosis can be done. Otherwise you could be throwing irrelevant parts at the problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
this was my topic originall a freind of mine told me it was a sensor in the tranny and that the sensor cost 500 dollars does this sound right
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
bignbad79 wrote:

No.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.