2007 Caravan Oil Usage

I have a 2007 Dodge Grand Caravan with 27,000 miles on it. A couple of weeks ago, the day before I had a dealer appointment for an oil change, the oil light came on. I found the oil level very low and
added 2 quarts so I could drive it in for the change. So they started me on an "oil comsumption test." I then left for a 2,500 mile vacation. I had to add 2 quarts along the way and it is now one half quart low. Are they going to tell me a quart per 1,000 miles is acceptable? I hope not. There is no leak and there is no smoke from the exhaust.
Is it likely that oil usage would be more, or less, in my normal city driving than in this vacation trip? Perhaps I should continue the consumption test with city driving?
I don't know if this is related, but a few days before the recent oil change the check engine light came on and they replaced the EVG valve (if I remember the part correctly).
I have an extended warranty so any repairs will be covered (unless they say this level of oil usage is within acceptable limits.
Thanks, Ed
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

the van should not use any oil there is an oil leak somewhere i would start with the oil filter and then the oil pressure switch and maybe the drail plug place a piece of paper on the ground under the van and see if there is any drips
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks, but I park in the same place on my driveway every day. There are no drips at all. If the oil is leaking onto the engine and burning up there would be smoke. There is no smoke.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

They may well say that this level of consumption is within limits, unless you have a very customer friendly dealership.
Let us know what happens.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

if the van is useing a quart every 1000 miles there is a problem since the motor has very few miles there has got to be a leak some where or it is burning it in small amounts and you can not see it
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

My dealer says it is probably a problem with the rings. He is ordering parts and they will take care of it next week. It'll be in the shop for about three days and they will give me a loaner.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.