Need info on adjusting timing belt for a 1990 Dodge Caravan

My distributor was loose and everything inside was torn up, I am replacing the timing belt and would like to know how to set the marks correctly. It
is a 2.5 motor. Is there any possiblity when the everything was torn up, did it damage the computer. The ignition coil has been changed, but I still have no spark. Thanks in advance for your help
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You "are" replacing the timing belt (doing it now) and you say "I still have no spark" which is it? you cant have a spark if you are in the process of installing a timing belt. You say it torn up the distributor and the "coil" has been replaced........What about the tore up distributor????? was it replaced??? is that why you have no spark either???? And no it did not damage the computer.
Glenn Beasley Chrysler Tech

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The distributor was not torn up, only the inside. I replaced the dstributor cap, rotor, and the pickup coil and then didn't get a spark, so I am now replacing the timing belt, but I don't know how to set the marks because I can't find a book that tells me about the 2.5 motor and how to set the timing marks. When I said I didn't get a spark, that was after replacing the other things, so I bought a timing belt. I haven't, installed it because of the timing marks. Is it possible that you might have something that you can send me to show me what to do. Thanks for your help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

trans you will see the mark on the flywheel and the degrees on the bellhousing. make sure the distributor is pointing to number 1 plug wire (on the cap) and the cam shaft gear will have a small hole in it, make sure that hole is up towards the sky, you will see to arrows on the gear in the center, line those up with the cam shaft cap straight -------- at the point wear the cap meets the mating surface of the head. good luck Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks maxpower, for all your help. I still am having problems though, I have done all the things that you told me to do, but I still can't get any spark. Is there anything else that would prevent me from being able to start the engine? Thanking you in advance for your help.
Terry C. P.S. Is it possible, could you send me a diagram of the markings to my home address?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I cleared my post and dont remember what we were talking about, repost
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Terry all you have to do is google it.........here, a good sight on timing belt settings, if yours is a 2.2/2.5 engine they are all the same, good luck http://www.turbovan.net/timing.htm
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks again maxpower, this will help immensely.
Terry C.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Maxpower, I am still trying to get this van working. I still do not get any spark period. Where is the computer located and do you possibly have a schematic for this motor, or know a web site where I can obtain one. Are there any sensors or relays that control the spark, and if there are where are they located. The coil has been changed, the distributor, the pick-up coil, the cap, the wires, and the timing belt, is there anything else you can suggest that I might do to get this car moving again. Thanks Terry C.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

dont remember what we were discussing. resubmit all info
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My distributor was loose and everything inside was torn up, I am replacing the timing belt and would like to know how to set the marks correctly. It is a 2.5 motor. Is there any possiblity when the everything was torn up, did it damage the computer. The ignition coil has been changed, but I still have no spark. Thanks in advance for your help
You "are" replacing the timing belt (doing it now) and you say "I still have no spark" which is it? you cant have a spark if you are in the process of installing a timing belt. You say it torn up the distributor and the "coil" has been replaced........What about the tore up distributor????? was it replaced??? is that why you have no spark either???? And no it did not damage the computer. Glenn Beasley Chrysler Tech
The distributor was not torn up, only the inside. I replaced the dstributor cap, rotor, and the pickup coil and then didn't get a spark, so I am now replacing the timing belt, but I don't know how to set the marks because I can't find a book that tells me about the 2.5 motor and how to set the timing marks. When I said I didn't get a spark, that was after replacing the other things, so I bought a timing belt. I haven't, installed it because of the timing marks. Is it possible that you might have something that you can send me to show me what to do. Thanks for your help
Ok, make sure #1 piston is up on TDC 0 degrees, looking thru the hole on the trans you will see the mark on the flywheel and the degrees on the bellhousing. make sure the distributor is pointing to number 1 plug wire (on the cap) and the cam shaft gear will have a small hole in it, make sure that hole is up towards the sky, you will see to arrows on the gear in the center, line those up with the cam shaft cap straight -------- at the point wear the cap meets the mating surface of the head. good luck Glenn Beasley Chrysler Tech
Thanks maxpower, for all your help. I still am having problems though, I have done all the things that you told me to do, but I still can't get any spark. Is there anything else that would prevent me from being able to start the engine? Thanking you in advance for your help.
Terry C. P.S. Is it possible, could you send me a diagram of the markings to my home address?
Terry all you have to do is google it.........here, a good sight on timing belt settings, if yours is a 2.2/2.5 engine they are all the same, good luck http://www.turbovan.net/timing.htm
Maxpower, I am still trying to get this van working. I still do not get any spark period. Where is the computer located and do you possibly have a schematic for this motor, or know a web site where I can obtain one. Are there any sensors or relays that control the spark, and if there are where are they located. The coil has been changed, the distributor, the pick-up coil, the cap, the wires, and the timing belt, is there anything else you can suggest that I might do to get this car moving again. Thanks Terry C.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Maxpower, here is a copy of what I sent before and your answers:
My distributor was loose and everything inside was torn up, I am replacing the timing belt and would like to know how to set the marks correctly. It is a 2.5 motor. Is there any possiblity when the everything was torn up, did it damage the computer. The ignition coil has been changed, but I still have no spark. Thanks in advance for your help
You "are" replacing the timing belt (doing it now) and you say "I still have no spark" which is it? you cant have a spark if you are in the process of installing a timing belt. You say it torn up the distributor and the "coil" has been replaced........What about the tore up distributor????? was it replaced??? is that why you have no spark either???? And no it did not damage the computer. Glenn Beasley Chrysler Tech
The distributor was not torn up, only the inside. I replaced the dstributor cap, rotor, and the pickup coil and then didn't get a spark, so I am now replacing the timing belt, but I don't know how to set the marks because I can't find a book that tells me about the 2.5 motor and how to set the timing marks. When I said I didn't get a spark, that was after replacing the other things, so I bought a timing belt. I haven't, installed it because of the timing marks. Is it possible that you might have something that you can send me to show me what to do. Thanks for your help
Ok, make sure #1 piston is up on TDC 0 degrees, looking thru the hole on the trans you will see the mark on the flywheel and the degrees on the bellhousing. make sure the distributor is pointing to number 1 plug wire (on the cap) and the cam shaft gear will have a small hole in it, make sure that hole is up towards the sky, you will see to arrows on the gear in the center, line those up with the cam shaft cap straight -------- at the point wear the cap meets the mating surface of the head. good luck Glenn Beasley Chrysler Tech
Thanks maxpower, for all your help. I still am having problems though, I have done all the things that you told me to do, but I still can't get any spark. Is there anything else that would prevent me from being able to start the engine? Thanking you in advance for your help.
Terry C. P.S. Is it possible, could you send me a diagram of the markings to my home address?
Terry all you have to do is oogle .........here, a good sight on timing belt settings, if yours is a 2.2/2.5 engine they are all the same, good luck http://www.turbovan.net/timing.htm
Maxpower, I am still trying to get this van working. I still do not get any spark period. Where is the computer located and do you possibly have a schematic for this motor, or know a web site where I can obtain one. Are there any sensors or relays that control the spark, and if there are where are they located. The coil has been changed, the distributor, the pick-up coil, the cap, the wires, and the timing belt, is there anything else you can suggest that I might do to get this car moving again. Thanks Terry C.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

here. I have no idea what you have done . My suggestion is to have someone with a scanner look to see what is going on
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Related Threads

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.