Need Dakota detectives

Ok folks heres the problem: 02 Dakota V6 4x4 70,000 mi. No check engine light and no codes when keyed on/off 3 times. Truck would not start this
AM. Hasn't run in about a week. Weather is getting colder,damper and the battery is original. Tried jumping from wifey's car. No start. Let it sit on the cables for a while with wifey's car running and tried again--no start. Turns over but no start almost sounds like no fuel but tank is full. On third try took the pedal to the metal (not usual way to start it) and she finally kicked over but as soon as I let off pedal she stalled. Did this a few times and she finally held on after I sat with my foot on the gas and kept it idling at about 1K. She now sits idling all by herself in the driveway--thought I'd let her warm up and see if getting rid of some moisture helps. I expect I need a battery but something else is wrong--any ideas out there? TIA for any advice offered.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
mowingy wrote:

New Battery. Sounds like the old one is bad enough that it isn't turning the fuel pump well enough to build pressure in the rail.
--
Steve W.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.