94 Escort (UK) Fusebox HELP

My fusebox is playing up, and I need to get it out to have a look at. How on earth does one do this? There's not a single piece of information on how to
do it in the oh so usesless Haynes manual.
I've released it from the catch thing at the front, disconnected the connectors, but it's not moving anywhere.
Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
after removing the front panal(6 screws)theres a catch at the front it now should drop down(sometimes a cable tie keeps it up)look at the back theres two peg like things on two sliders slide it forward and drop it down. look on the sliders theres two holes for it to come out(you may need a torch to see them)
note; fuseboxs are a common fault on this model
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the information.
I found a couple of the relays contacts were BLACK, i wire brushed them clean and put them back in, see how the problem goes.
I have read in various places/forums that the fuseboxs are a common problem and are a silly amount of cash for a new one. Any ideas how fixable they are if my problems persist?
Cheers.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i once took one apart only to find the printed circuit was all corroded away by water, i think this happens to them all
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.