Radio Installation

I had received a Metra Turbokit Auto Stereo Installation Kit for my birthday. I came with wire harnesses that were supposed to fit my vehicle. My vehicle is a 2000 Ford Escort ZX2. The item number is 99-5720. It
clearly says on the package that the item is made for my vehicle. The things that aren't working are the wire harnesses for the power and the speakers. All of the speakers wire are in one harness and everything else to power the radio are in another wire harness. Neither of these plug successfully into any of my previous plugs. What is going on? Why isn't it working and what can I do to fix it? I need answers as soon as possible.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I would suggest contacting Metra since they're the one who claims it'll work with your car. Most of them don't say they'll fit; most just say they're "compatible" with the vehicles listed. Good luck!
SC Tom
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
c_cook2007 wrote:

Could be the escort switched in 2001 harnesses... maybe try a 01 or 99 harness adapter
we ran in to this in an old 1990 buick century
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.