Focus 1.8 TDCi turbo problems???

Hi,
I test-drove a 1.8 TDCi Focus Ghia at the weekend, loved it, and bought it.
Picked up the car today, drives like a different car. It seems the
turbo just isn't kicking in at all, which means I struggled to hit 70mph (120kmh) on the motorway - it just completely runs out of power round about the 2000rpm mark. Does anyone have any suggestions what could be causing this? I'll be taking it back to the dealer, but if anyone else has suffered similar, I could at least give them a clue what to look at first.
Cheers
:-(
Stu
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
go to the dealer and ask for a roadtest with the foreman.im not going to say wot this might or might not be,cos without driving it myself, i could be sending someone,somewhere,( like me) down the garden path...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Turns out it was a faulty Turbo Boost Pressure Sensor.
ford_technical_ wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Stu wrote:

.....or not. Damn diagnostics giving me false hope!
They've now replaced that, and messed about with it for 3 days, and still can't get it running properly, so it's off to a Diesel specialist :-(
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.