Focus - unpleasant noise / feel through steering.

Hi All,
Re Focus 1.6 Ghia 2004 40K miles
Purchased this car six months ago and it was fine for first couple of months. Then one day after a 130 motorway journey I noticed an
unpleasant noise from the front end
It's not noticable at speed but very obvious when 'coasting' down a slight hill, i.e. power off.
It sounds and feels like the front disks have lost their pads and are rubbing badly - a metal to metal noise. (brakes are OK !)
Took the car back to dealer, who changed a tyre !
Took it back again and they admitted there was a problem but requested that I continued driving it to make it worse, and hence easier to find.
Eventually with the warranty about to expire I took it in again.
They suspected the gearbox, but then decided it was a wheel bearing. When I collected the car they had in fact changed the drive-shaft support bearing.
This of course wasn't covered by the warranty !
It improved a bit , but didn't solve the problem - the grating sound and feel is still there.
Any thoughts on what the problem may be, plus possible action now that the warranty has expired, are most welcome.
My argument has been that it was a 'sudden' failure - it was fine one moment, 130 miles later something had died. Warranty company says this is 'wear and tear'
TIA
Graham
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I came across this interesting tidbit on the Internet. Ford Focus 2002 recall. Loose bolt in the steering system can cause vibration, noise, and more serious problems. This probably isn't your trouble, but I thought I would pass it on.
On Mon, 22 Oct 2007 19:23:27 +0100, Graham C

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.