Need Help: Engine Light On - P0171 LEAN 1

My 2001 Ford Focus ZTS with 58,000 miles has the engine ligh on with the P0171 LEAN 1 code. I have already replaced the Oxygen Sensor, EGR Valve, PDF Sensor, but
the engine light still stays on. A mechanic also checked the vaccum,an it's OK. What else can it be???? Any suggestions?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Do you have modifications under the hood? Such as a cold air intake?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

No, no modificatons whatsoever.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If you think you have fixed your problem. Then take off the battery terminals and short them together ( so that the battery isn't hooked up anymore at all.. and turn your lights on.. Let it sit for about 5 minutes or so. This will completely drain your cars computer and will reset your error message.. Over the next 50km or so, if there is still an error.. the light will come back on. I hope this helps.
I had my light come on after I put a cold air intake on my focus. Turned out my MAP sensor was saying my car wasn't getting enough air. but my O2 sensor said I needed more fuel for the air that I had.. so my car was fighting with itself. Anyway, a mechanic told me that was how I was supposed to clear the error messages from my car

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.