a/c problem, emergency!!!!!!!

first off, i heard a wierd noise which sounded like it came from my compressor. After the noise it stopped working. I put in a brand new compressor now and it still does not work.
Thinking it might be electrical, I put in a brand new relay. It still does not work. And, yes it's full off 134a. A/c light comes on but does not engage clutch. And I did hook up the one wire on the compressor. I checked all fuses and they are good. I was woundering if anyone knew something else that might be the problem? would the expansion valve or dryer stop the compressor clutch from engaging? I'm at a loss right now and don't have the money for a expensive auto shop to fix it. It's a hot S.O.B. here.
--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/honda-cars/200806/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Keep replacing parts-- eventually you'll get to the right one......
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

good news is that the light comes on on the dash....
So what i would do is verify that the clutch does work. Disconnect the plug to the compressor and run a hot wire from the battery to the compressor side plug and you should hear it click on and off as you touch the hot wire to the connector.
Also, on mine the dual pressure sensor was gone ($20 at pepboys). Take an ohm meter, disconnect the plug on the pressure sensor and check for a short (0 ohms) across the connector.
We'll go from there...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.