Help With '99 Accent

So the dealership my sister bought her used Accent from replaced the entire gas tank free of charge as the gas guage wasn't working. (Apparently the had done the exact same repair a year ago which is why
they did it for free).
Now the problem is that it is very hard to get gas in the car. The pump keeps stopping as it thinks it is full.
Any suggestions?
Chris
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You have some sort of blockage in your evap vent circuit. Perhaps a hose was pinched when the new tank was installed.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

All stations or just a local one? I have stopped at stations with very high flow rates on their pumps that cause the fill sensor to kick off. The answer was to only open the nozzle part way. Other pumps around here only pump at a relatively slow rate. This also seems to be more of a hassle with stations with the "improved" sealing around the nozzle to keep fumes from coming out.
note: I'm not disagreeing with hyundaitech, just adding some factors to look at.
;-)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You make a good point, nothermark. That's certainly a possibility.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
hyundaitech wrote:

Thanks guys, you are extremely helpful!
:)
Chris
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.