e240 aircon

hi - is there a fuse for the aircon on a 2003 e class 240 - the aircon off button is flashing

--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I don't think that's a fuse. I have an SL 500 and my air con light was doing the same thing... and not blowing cold air. When I pressed the aircon button, it would come on solid and then start flashing again...(well, it either went out solid, or came on solid, can't remember for sure) for about 5 seconds or so and then it would start flashing again. I took it to the garage that works on my merc, he hooked the computer up to it and turned the aircon on with that and it was working. He reset all the computers in the car, and the light went out and then the aircon was working fine and could be turned on and off. It seemed that it was just a computer wanted resetting.. Not sure what a Merc dealer charges for doing that, I pay 40 for him to hook up the computer, that covers the cost of his having the computer and getting all the updates. Anyway, just read this and sounded pretty much exactly like what mine was doing.
Cheers
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.