Kia Rio 2002 Stalling at low speed

:? I have a 2002 Kia Rio LS Auto with just over 62,000km on the clock. Apart from some squeaking rear seat catches, (fixed with newspaper on
the catch), I have had no problems. UNTIL about 3 months ago. Then the car would stall occasionally if the speed dropped below 5km/hr. It didnt happen every time and would never happen when I was near the dealer! One day it stopped every time I slowed below 5km/hr. Not much fun in peak hour traffic. Cars, trucks and busses giving me horn blasts thinking I could not drive. On this one trip I nearly had 5 vehicles run into the back of the Rio. The only way I could drive it was to rev the engine in neutral and put it into Drive when I needed to take off. Hope the transmission will be OK. Now I discover Kia have to wait for some new software to come from Korea and I am told they have not even ordered the bits from Korea. Has anyone else had this problem? I discovered that the USA had a recall for a similar problem but it did not fix the stalling. Some reports say it made it worse!
PLEASE HELP ME
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
have a mechanic check 2 things. the Idle control valve, to make sure it isn't clogged with carbon, and is operating correctly, and the Crank Angle sensor. have the mechanic pull a code list at the same time, and see what codes are showing. This will tell you what is wrong.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"AussieGraeme" wrote: > :? > I have a 2002 Kia Rio LS Auto with just over 62,000km on the > clock. Apart from some squeaking rear seat catches, (fixed > with newspaper on the catch), I have had no problems. > [b:0ad6baee25][color=red:0ad6baee25][size:0ad6baee25]UNTIL > about 3 months > ago[/size:0ad6baee25][/color:0ad6baee25].[/b:0ad6baee25] > Then the car would stall occasionally if the speed dropped > below 5km/hr. It didn't happen every time and would never > happen when I was near the dealer! > One day it stopped every time I slowed below 5km/hr. Not much > fun in peak hour traffic. Cars, trucks and busses giving me > horn blasts thinking I could not drive. On this one trip I > nearly had 5 vehicles run into the back of the Rio. > The only way I could drive it was to rev the engine in neutral > and put it into Drive when I needed to take off. Hope the > transmission will be OK. > Now I discover Kia have to wait for some new software to come > from Korea and I am told they have not even ordered the bits > from Korea. > Has anyone else had this problem? > I discovered that the USA had a recall for a similar problem > but it did not fix the stalling. Some reports say it made it > worse! > > PLEASE HELP ME
I have also same problem. Some time when I slowed my car before stop sign or wait for signal, my car stalled. I dont know how to fix it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had the same problem recently. I have had the same problem about 5 months back, but it happened only once and I kinda ignored it.
I also noticed something else, when the car stalls, the handbrake is hard to pull. But when I reverse the car, this releases the handbrake too and car moves.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"AussieGraeme" wrote: > :? > I have a 2002 Kia Rio LS Auto with just over 62,000km on the > clock. Apart from some squeaking rear seat catches, (fixed > with newspaper on the catch), I have had no problems. > [b:0ad6baee25][color=red:0ad6baee25][size:0ad6baee25]UNTIL > about 3 months > ago[/size:0ad6baee25][/color:0ad6baee25].[/b:0ad6baee25] > Then the car would stall occasionally if the speed dropped > below 5km/hr. It didn't happen every time and would never > happen when I was near the dealer! > One day it stopped every time I slowed below 5km/hr. Not much > fun in peak hour traffic. Cars, trucks and busses giving me > horn blasts thinking I could not drive. On this one trip I > nearly had 5 vehicles run into the back of the Rio. > The only way I could drive it was to rev the engine in neutral > and put it into Drive when I needed to take off. Hope the > transmission will be OK. > Now I discover Kia have to wait for some new software to come > from Korea and I am told they have not even ordered the bits > from Korea. > Has anyone else had this problem? > I discovered that the USA had a recall for a similar problem > but it did not fix the stalling. Some reports say it made it > worse! > > PLEASE HELP ME
:) The Kia dealership explained that the software is still under development in korea and not expected for a few months.
I showed them your advise and they said that the computer codes were all OK. They also said that they have had some others with this problem and one said the Map Sensor was faulty. This was replaced in all those Rios stalling for no reason and the problem went away.
They replaced my Map Sensor (I have no idea what this is) and my Rio has run perfectly ever since.
My guess is that there are a few dry solders or poor connections in this sensor and this causes the stalling at low speed.
As this was done last week I still have my fingers crossed that the problem is solved and not just waiting to come back!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.