Pug 306 1.4LX 1999 WONT START!!

Could anyone share any info to me about why my Peugeot Phase 3 T reg 1999 306 1.4lx wouldnt start when it was just getting ready to go for its
MOT!!!!!!!!
Iv checked everything preaty much, all the fuses, electrics, spark plugs, injectors. sprayed all with WD-40
I also fitted a new battery and have replaced fuel cut off switch and fuel pump relay ages ago, i know all these are working because the day before the mot i was running the engine at idle and cleaning the car till i turned it off and went in.
What happens now. When i turn the key the lights all come on as normal on dash and fuel pump primes, i then turn the key further, then the starter motor starts turning the engine but theres no fire. I have checked the coil pack by removing it and stickin a screwdriver up there but theres no spark (that goes on the sprak plugs). I got my multimeter out and stuck it into the 1 of 3 pins in the connector for the coil pack.
I am gettin a +12v reading from on of the pins when i turn the ignition on by the key, then goes to 0v then when i turn the key to start it goes back to +12v. the other two pins coltages are around 0.40v.
I have check nearly everything that iv read on here for example, gearbox earth, wiring, fuses, fuel cut off switch, etc etc
So... Im guessing there is something wrong with the transponder key not picking up and not letting it fire or its got to be the coil pack? Because the fuel pump is priming so this means theres no problems with the ecu.
Is there a special way to re program the key as i have already tried leavin it over night with the battery off and trying again, held the blip button down while turning the key etc etc.
Or is there something else i have missed or i could be completely wrong...
Anyone have any suggestions please help? I need my car to go to work and earn money as im in loads of poo :(
Many thanks
Furio
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@yahoo.com wrote:

try and remove the igititon swith the back of it. and turn that bit with a screww driver it might be the key or by pass the ign swith and go to starter motor,i think its some thing with the ign swith.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.