cooling issues

1995 Grand Prix, 4 door, 3.1, automatic. Cooling fans won't turn on. Tested the fans to battery and they work. Put new fan relays in, and new
temp sensor. Fans still won't turn on. Any ideas?? Approx. temp should the fans turn on at? Any and all help would be greatly appreciated. Thanks in advance.
Tim
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Tim.
My 94 fans come on at 220-250 degrees ... try using your AC fan (if you are equipped)

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Tim, If you replaced and tested the fan and relay switch. I would look at the actual plug that goes into the relay switch. It could be bad. Put a jumper wire in the plug just to test the fan. If the fan doesn't come on...by-pass the plug. (you may have to cut the wires going into the plug, but it sounds like a faulty plug.also...look for broken wires.
Tim Long wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks to all that responded!! Turned out to be both relays were bad and the temp sending unit was marginal. Thanks again for all the info.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.