Prius Mode setting blank

I have found that if I leave our 2015 Prius Four in "Power" mode when I
switch it off, when I switch it on again there is no "Mode" indicator at
all -- blank where the Mode indicator normally displays.
What Mode is it actually in at that point? -- doesn't feel like Power
mode when I hit the accelerator. I'm guessing that it's in ECO Mode, but
why doesn't it display that?
Perce
Reply to
Percival P. Cassidy
Thanks, Pat. We are newbie Prius drivers and hadn't realized that there was a "Normal" mode in addition to the ones activated by the labeled buttons. When I Googled the modes, I found suggestions that in many situations "Normal" may be preferable.
Perce
Reply to
Percival P. Cassidy
Interesting. Why do they believe normal is better? I typically use ECO because I like to see high mpg's. I sometimes use power when entering a busy freeway but then I go back to ECO. I do notice that when I rent a car (non-Prius), I tend to press the gas pedal too hard at first because I am so used to driving the Prius in ECO mode.
Pat
Reply to
Pat
This is what I found first of all -- a basic description of the different modes:
I can no longer find the thread where people were suggesting that Normal is better, but it was on the priuschat forum.
Perce
Reply to
Percival P. Cassidy

Site Timeline Threads

MotorsForum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.