2014 Forester hub bearing diagnosis

Hi All,
I have a 2014 Forester with ~135k miles on it. I have noticed a humming coming from somewhere at highway speeds.
I just replaced a bad tire (it had thrown a belt), that I thought may be contributing to the noise, but the hum continues. Its pitch is related to road speed (not engine speed), and doesn't seem to change much when turning.
I think I may have a hub bearing going out, but how can I find which one? I have not (yet) put it on jacks to see if I can tell by wiggling. It is difficult to ascertain where the hum is coming from while driving.
Sincerely, Duane
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 6/14/2018 7:00 AM, TheSeeker wrote:

With Subaru AWD, I have always thought that all tires should be the exact same diameter and if you replaced a bad old tire with a new one that might be the problem and maybe worse than wheel bearing.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Thursday, June 14, 2018 at 2:59:51 PM UTC-5, Frank wrote:

I replaced the bad tire with another used tire of the same circumference, because that is what I had heard about Subaru AWD as well.
Duane
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 6/14/2018 8:03 PM, TheSeeker wrote:

That's good. I had heard that some shave a new tire to the same size.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.