ABS Light on 90 4-Runner 4x4

    Hi, my 4-runner's Rear ABS light just came on. The breaks seem to be working fine. Is there anything I should check before I take it
to the shop? BTW its a v-6 with 238,001 miles Thanks Poindexter
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On the 1990 4runner, the rear ABS light should be on ALL the time. This indicates that it is working. If it just came on, their maybe a problem with its wiring or the bulb. Can't say if this indicates a problem with he ABS system though.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If this is like my Tacoma, the idiot light for the ABS system will come on if one of the sensors at the wheels fails or the ABS system has been disabled. The ABS will be in disable mode if the light is on. I had to take my truck to a dealer so they could check the codes and see which sensor had failed. I had to replace the sensor on the front, drivers side wheel. I never could get used to ABS and had a couple of close calls because of it. Rolled into the middle of intersections twice where I know I could have stopped easily without ABS so I disabled the ABS by removing the fuse for it a couple of years ago. My ABS light is always on so that drivers are aware that it is not working.
Kevin http://home.off-road.com/~tacomas_offroad /
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.