Check engine light

I replaced the oxygen, temp, and speed sensors, also replaced thermostat, fuel pump, spark plugs and gave a diagnostic and check engine light remains on while driving and overheats occassionally for
lack of fans turning on. Found a short in fans, now they are working and gave another diagnostic, tried to erase the codes, they will not erase and got these codes P1698 and P0500 after all this has been done. When test driving in (drive) the van will not go out of 1st gear and these codes still remain with the check engine light on. Does anyone have any suggestions, please help....Laura
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

My first suggestion would be to tell the group what kind of vehicle this is. Year, make, model, engine type.... why do people constantly need to be reminded of this?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Tom Lawrence wrote:

I'm sorry its a 1997 Plymouth Grand Voyager Se 3.3 engine V6
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have a 1997 Plymouth Grand Voyager Se V6 3.3 engine and I replaced the oxygen, temp, and speed sensors, also replaced thermostat, fuel pump, spark plugs and gave a diagnostic and check engine light remains on while driving and overheats occassionally for lack of fans turning on. Found a short in fans, now they are working and gave another diagnostic, tried to erase the codes, they will not erase and got these codes P1698 and P0500 after all this has been done.
When test driving in (drive) the van will not go out of 1st gear and these codes still remain with the check engine light on. Does anyone have any suggestions, please help....
Thank You, Laura
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
From the MAX MicroTuner guide P0500 No Vehicle Speed Sens Signal P1698 No CCD/J1850 Message From TCM/PCM
Since you say you have changed the speed sensor and with the fan problem I would suspect more wiring problems.

Happy Camping. snipped-for-privacy@NOPANTS.juno.com Remove NOPANTS To reply by direct E-Mail;
2003 Dodge 1500 QC SB Hemi, A/T, Tow Package, 3.92 gears (11 mpg Towing) 2001 Aerolite 21RDB 21ft TT (Scales 2900 dry)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Remember you made some cheap shot about me visiting Hole on one of my trips to FL???
I know your gonna love this one!<BFG>
Yes I suppose go a little out of my way and visit Hole, then run right up I-75 and visit YOU!!!! Hell, you two are about neighbors. I'm sure he'd help you with some plowing if ya fall a little behind.<VBG>
If you are real nice I'll post his phone number for ya. Maybe you two can hook up and do lunch.<BG>
You gotta know I'm sitting here laughing my fat ass of on this one!
<GBMFG>
Roy
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
hey man out of curiosity how's the search for a camper going?
--ref "enough truck" aug 9 thread
--
----------------------------
-Chris
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.