hose lookign funny

Hello again all!
I have been diligantly working on the suggestions (any newcommers please don't hesitate to check out my other topics- I'll talk all the
help I can get :)
Two things I have noticed since 1- there are 2 O2 sensors!! haha, so I have another on the way- perhaps that will solve the other problems with the high idle and such (I have changed the tp sensor and the idle air intake control thing-a-majig with very little effect on the problem).
NOW the new one.... I have noticed during a vacum line inspection (of which was unseccessful- sounds like the whistle is coming form right by the drivers-side firewall... somewhere... so hard to follow a whistle!) anyhow, I noticed a "blown up" tube attached to my T-stat housing. Not the big hose from the radiator... a small hose, it's not leaking, but it's blown up like a small ballon- which can't be good. I'm not sure what hose this is... could it mean the T-stat is stuck closed (but it seems to me it can't be cause my temp fluxuates and the hose gets loose like it has opened when it's getting warm.
Thanks for any and all help!
Luke
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If the Hose looks funny...do what I have always done when seeing a funny hose....laugh at it! "Funny hoses are made to be lauged at"
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.