96 Accord - ABS Light Comes on, Radio shuts off, Clock resets...???

Hi,
I have a 96 Accord EX with 181k on it. For the past couple of days my car stereo has been shutting off intermittently, like there is a short
somewhere. At first I just assumed it was a prolem with the stereo itself, but I noticed last night that the ABS light comes on and whatever the event that causes this to happen also shuts off the stereo for a few seconds. The ABS light goes off for a few minutes and then comes back on, shutting off the stereo again and the cycle repeats.
When I was pulling in my driveway last night it seemed like the headlights flickered ever so slightly, but I can't be sure I wasn't just imagining the barely perceptable change. But when I went to start the car this morning, the clock had reset and the ABS/radio issue was more frequent. I also noticed that when I shut the car off the power locks didn't work the first time I tried them. I waited a minute or two and then they worked fine, but obviously I am concerned about this and am hoping someone can offer some insight into what the problem/fix might be. I checked the fuses and the all seemed to be okay. Any help would be HUGELY appreciated!
Cheers, Virtual Elvis
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

First thing I'd check is the battery cables (most specifically the ground cable) and the batteries over all condition (age, load, voltage at rest and with car running). Low battery issues can be tricky and seem random.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tue, 22 Sep 2009 14:48:57 -0400, "Seth"

Good Advice. I agree.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.