Service Vehicle Soon Light

2000 Century.
Does anyone know what SVSL monitors? The owner's manual doesn't say.
Thanks.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i have a '95 Century, may not have anything to do with it, but, when mine comes on, it has already turned on the fan from sitting still for a while or in slow slow traffic, where the air is not being blown into the air intake thing under the hood, then after mine goes through another "cycle" of turning the fan on and off, doesn't take too long at all, and the light goes off......that is what mine does.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds more like your "Check Engine" light and that your fan may be delayed in starting.
Cheers
snipped-for-privacy@yahoo.com wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It's not the Check Engine Light. The light is not on at the present time and the bulb is good. Just wondering what it monitors that's all.

"The service vehichle soon light will come on if you have certain non-emissions related vehicle problems. These problems may not be obvious and may affect vehicle performance or durability."
Weird wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I can't verify all the things it monitors, but on my '01 Pontiac, it does at least monitor the exterior lights. So, as a starting point, look for a bulb out.
Cheers
snipped-for-privacy@idirect.ca wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

My car has the OBD1 system and when my telltale light comes on, it is always an EGR complaint. There is nothing wrong with my EGR system, so I started monitoring the gas brand I am using when the light illuminates. I've found that using gas with Techron (sp?) doesn't cause the light to come on. You might try checking for trouble codes and use that info to track down and intermittent problems.
Dave S(Texas)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.