Jaguar s type engine failsafe error message

Help, I have recently bought an s type and just today the error message ' engine failsafe mode' has been appearing only occasionally. can anyone help and
advise what this means!!!!!!!!
Thanks
--
sufos

------------------------------------------------------------------------
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I feel your pain. Mine has done the same. Started slow and somewhat cheaper as compared to now. i've changed clock spring module, ignition coil, spark plugs, o2 sensors, ball joints, resonators, tie rods, wheel bearings, stablizer links and so much more. I've had failsafe engine mode, dsc system failure then shutdown, another warning about fuel system. Many lights, all colors, like a christmas tree and it changed daily. Now i've got no compression, car does not start a timing issue, and still have payments left. If you are like me, love the car, it's history and it is a dream come true; But this dream quickly becomes your worst nightmare! I wish none of this ever happened; as I still say ok but is is so much fun to drive; that is when it started. And that's over a month ago. Now I'm about to take a 20k loss on a car i've owned for 13 months. My advise is stop the bleeding, sell it and never look back. My father told me before I bought mine there are 2 kinds of jags good ones or really bad ones...theres no middle of the road. I now think the good ones are only fables like a unicorn. Best of luck to you, but mostly you have my sympathy. I only hope you have better luck than I do as i's costing my about 3,000 per month just to keep it running, and not running great either. It's just not worth it, so cut your losses while it's not so much. Sorry
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi
I have an S type and had the same problem. It has been in and out fo the garage and cost me far too much! However, since having new coils fitted it seems to be OK. Now I have a problems with a click on the break pedal. Back to the garage! I really should sell it but I love the car so much.
Good luck, hope you get it fixed.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.