Nissan primera reversing lights not working

Not sure whats going on, checked all fuses by the drivers seat which are all fine. When the car is in the reverse gear, the reversing lights on the back do not
come on. I have checked the bulbs and the connections on the back of them which appear to be fine. In the fuse box there appears to be no reference to the reverse lights at all. Any ideas guys?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Swiss Tony wrote:

Hi It sounds like it could be the switch that is in the gearbox or corrosion in the connector. Try bridging the contacts and if the lights work then it's the switch that's a fault. Trevor Smith
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi The is a fuse box next to the battery under the bonnet I know the side light fuses are there perhaps the reversing light fuses are there too
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Dave4u wrote:

Hi Dave No the fuse is not there it is in the fuse box by the drivers door (RHD) on the P10 Primera and the same fuse controls the gauges/warning lights and the feed to the heated rear window relay, so if all those items are working it's not the fuse. Have you checked to see if you are getting 12 volts to the bulb connector when you select reverse?, if not then it is either a faulty switch in the gearbox or more likely corroded/broken wire in the connector block from the gearbox. If it is an automatic then I can't advise as I have no knowledge of the light switching on autos, it could either be on the stick shift or the box it's self. Trevor Smith
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.