1997 Grand Prix GT - ABS & Traction Light On/Off

I recently replaced the front & rear brake pads on my 1998 Grand Prix GT. Prior to doing so, everything was fine. Upon putting on the new pads, I
began to get an ABS/Traction indication. It doesn't occur all the time, but once the car has been use for a while, the ABS light comes on, and the Traction light comes on. Once the light is on it stays constant even when shutting down the engine, waiting a while, and turning it back on. I did not touch the ABS sensor, or the electrical connections. Has anyone experienced this problem? And/or has anyone any suggestions on how to resolve.
P.S. I checked to see if there was any dust where the sensor is, and also checked to make sure that the sensor was in position. All checked out fine. I'm at a loss. Please help!
Thank you in advance!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Needs to be scanned with an abs capable scanner to find the problem.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had this exact same problem last year and I have the exact same car; the lights would come on for me after driving for a while (but I'm pretty sure it was that I had to surpass a certain speed). I had to have a computer check done but there was a sensor going bad in one of the hub assemblies and the assembly had to be replaced. I can't remember what it cost but hopefully that'll give you an idea of what to look for.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.