'93 Saturn SL1 won't start

I have a saturn sl1 '93 that will no longer start. I think that the ignition switch is good. I went to start it the other day and when I put
my key in the ingintion all the dash lights came on anlong with the radio but not the engine. I did not hear any noise (such as clicking) I tried again on about the third time it started what appeared to be normally. I went to the store just 2 mins down the road went in for about 5mins when I came back out it started fine. After being home for aproximately 15-20 mins I went to try to start it again this time even after several tries it will not start. You can not jump start it but you can push start it and it seems to run fine after doing so but once it is off the only way to start it is to push and pop the clutch. As i said the ignition appears to be good and the battery has been checked and is good as long as the connections to it. What is the problem and how do I go about fixing it?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
In article
snipped-for-privacy@earthlink.net says...

Well sinces its manual it could be your clutch switch. I think you could hold the key to start and move the clutch in and out. If that doesnt work, set the brake, jack up the front, use stands and blocks, use someone you trust to hold the key and then go around and jiggle the wires. Sounds like some corrosion on some contacts.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.