850 auto transmission problem

Hi akk, wonder if anyone can help with an auto transmission problem on a '94 850, with 140k miles on it.
Smooth changes around town, never a problem.
Get up to speed, 50-60ish, all nice and smooth.
When I slow down, about half the time I get a "clunk" that you can feel through the car as I slow down through 20mph, and another as the car comes to a halt.
If the "clunks" have happened, it also does the same thing when moving off.
Any thoughts? Nick
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

'94
off.
ATF ever been changed? Start there, a good flush and replacement. Box could be approaching toast though :(
Tim..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

could
ATF OK, box smooth as anything most the time. It feels much more like a control issue than a box issue. Maybe the box has had it :-(
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

'94
off.
I wonder if you have checked the engine mounting on the top of the motor that stops the engine rotating on its axis (i.e. front and backwards). I believe these fail regularly. It may be the cause of your noise.
Regards Barry
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I've not checked the engine mounts, but will now. I'll report back after I've had a look.
Cheers, WM
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I
I've checked, nothing looks wrong there. Must be somewhere else :-(
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.