Help - starter problems

Hi, recently I just replaced my starter. After 2 months or so it started to act up again. I turn the key and the motor cranks over once, then it
goes dead. It doesn't start or keep cranking the starter it just stops. If I hold the key in the start position, it will crank the engine over once then go dead after a 2 secs pause, it will turn over the engine once then go dead 2 secs later it will turn over the engine once then go dead. It does this 4 times then the car will usually start. Its always the same amount of time it take the starter to crank the engine after the pause. Its like a cycle. The odd time I will turn the key and the starter will turn the engine over till it starts. Its a 89 Daytona 2.5 turbo. Any ideas where to start to check this out. To change the starter it is a big job. Thanks in advance. Sorry Dan C... not going to take it to the wreckers yet.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sun, 01 Apr 2007 03:20:36 GMT, "2cold2early"

Check ALL connections, including grounds to both engine and body.
--
Posted via a free Usenet account from http://www.teranews.com


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

as mentioned before check all of your connections. be sure and clean them and use a little dialectric grease when you reassemble them. did you install an oem started or one from a discount parts store? michael
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.