2000 Ford Taurus, Intermittantly won't Start

Hello Everyone,
I'm baffled by the car trouble I have been having recently. I purchased a used 2000 Ford Taurus 3 months ago with about 54k miles on it in supurb
condition. No problems at all, they had all their paperwork on all work done on the car and all the oil changes, flushes etc done timely and documented.
The problem I am having is intermittant and because of this 2 auto shops I have taken it too don't have a clue what it could be, I think its only a matter of time before it just won't start period and maybe that's what I have to wait for to get them to figure out what it is and fix it but I'm trying to find another way in case this intermittant problem continues for a long time.
Over the past 2 months occasionally I would have a problem with the car starting, I'm not a mechanical wizard so I will just tell you what I know and if you need to know more just let me know. When I would attempt to start the car nothing would happen except that you would hear a click, click, click and 2 lights would be on on the dash, everytime the car clicked the Theft light would flash and some other dash indicator as well that I don't know what it means as of yet. Initially my thoughts were to the battery but the first time this happened I had someone coming to give me a jump and just for the hell of it I tried to start the car after 10minutes of leaving it alone and blamo it started mysteriously. It happened again a week or two later but after trying several times I just let it sit for a few mins and blamo it started again.
Just this week it has become increasingly frequent, It wouldn't start on Tuesday so again I thought battery, so we attempted to jump it and all I got was Click, Click, Click at a faster rate and again the Theft light blinking with the clicks and the other indicator lighting on the dash. So I said I would have to get it towed etc and left it there to go to lunch when I came back from lunch I tried it and blamo it started once again. Then yesterday once again it did the same thing, wouldn't start, tried several times with the same indicators, left it alone to call for a ride and then tried again and blamo it started. So I took it to an electrical specialist and they tested the battery and alternator and they both came up fine and they couldn't do anything for me because of it being intermittant, I took it also to Advance Auto Parts where they tested it as well with the same results. So I'm sitting here with a car that will either start or not at what seems the flip of a coin with no clue what the trouble is. Again tonight it did it once again, with the same indicators, I went in to get something to try and reach and hit the starter as someone told me to do in case thats the problem hitting it would help but when I came back out I tried again and blamo it started.
If any of you have and ideas please let me know because this intermittant problem is going to make me pull out my hair and now 3 days in a row it has happened so who knows how long it will go on before whatever is broken totally dies. Thank you everyone.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Sounds like a starter solenoid to me. Don't recall if they're integral or separate on the Taurus. Make sure ALL your connectors between the battery and starter are clean and securely fastened. (including grounds).
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Strange I have the same problem and my repair garage change the starter still nothing change. My car stop anywhere and restart alfer few minutes.
email name wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.