Injector Pluse Width Jumps around

Still trying to pin down what initiates the herky jerky episodes. One anomaly in the scans is occasional rapid changes in injector pulse width. E.g., suddenly goes
from 5.3 ms to 2.3 ms in a 1/4 second, then returns, while throttle angle & road speed are not changing. What could cause this?
Is there a MAP sensor in this system? Id so, maybe an intermittent vacuum leak?
TIA
Ed
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
A little information on type of car, engine, etc might get you some answers.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Oops! It's a '95 Buick Park Ave Ultra (supercharged 3.8L)
Ed

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Ed's been keeping the group advised of his efforts on this car for months. This is an ongoing thing, not a new post. You've been around here a while, I'm surprised you haven't seen the herky jerky posts.
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mike,
Well, let me take the blame here. Can't expect everyone here to be 100% attententive to my trials and tribulations!
Ed
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.