1995 Explorer EB will not start.

My 1995 EB has been hard to start for a few months, especially when it is cold in the mornings, but it always has started. After it sat for a week
without running, it will not start. The fuel filter was old so I replaced that and verified that it is getting fuel. (The old filter was clogged. I could not get air through it.)
The battery is charged and the starter is spinning the engine rapidily. I verified that that plugs are getting power, by removing a plug wire near the distributer and watching it spark.
I tried to run the Key On Engine Off test with my ECC scanner tool, but nothing happened. The scanner light just stayed on. Any ideas on what this means? Also, when I turn the key on I hear a sound from the rear of the car, probably the fuel pump. It does not stop and I can't recall this being the case before. Does this sound like a problem also? Where should I start?
(No flames for this please :-), but the plugs are probably the original ones. Should I just start by replacing the plugs and possibly the wires?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

How many miles are on it? You make it sound like it's very neglected. How's the air cleaner? Personally I'd rather keep up with the maintenance so usually only one thing goes wrong at a time ;-)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.