VW Polo possible misfire

My brother called me this evening because he thinks he has a problem with his VW Polo (1.0 litre, V-reg). He says the engine 'judders'
sometimes, but only when it's warmed up. He says it happens when using lots of throttle between 2000 and 3000RPM, and also when idling (but not enough to make it stall). I'm guessing it's a misfire of some kind, would that be the best guess? I'm visiting on Saturday anyway, so I said I would have a drive and a look under the bonnet. I can check for the obvious ignition stuff (HT leads, spark plugs, dizzy cap), any suggestions for other stuff to check? I've told him it could be a dodgy sensor or similar, in which case it would have to go to a garage, but I'd be grateful for any tips of things I can check for on Saturday.
TIA...Nick.
--
Nick Challoner, snipped-for-privacy@challoner.com
Aviation photography: http://www.challoner.com/aviation
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Check for a gunged up MAF.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Depresion wrote:

Or a gunged up throttle body. Be aware that if you remove the throttle body it may need a adaption afterwards.
Actually, SWMBO has a 1.4 Lupo that did this and it was vastly improved after a TBA.
http://wiki.ross-tech.com/index.php/Throttle_Body_Alignment_ (TBA)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.