Vibration/Drone '94 GT

A vibration/drone just started on my last highway trip. I'm thinking it may be exhaust but... Here's what happens.
At a sustained speed between 55 to 60 mph there is no vibration/drone but
when you back off on the throttle you can hear and feel vibration/drone. No change in symptoms if shifted into neutral. However at a sustained speed of 75+ (engine under load) the vibration/drone is constant except when you release the throttle than the vibration/drone stops until the car slows to 60- mph. This is making no sense to me. I can see where either circumstance would occur but I would suspect that it should be one or the other.
The mufflers are stock Ford and may be original. Car has 73k miles. I can't say that there is a change in performance/acceleration. Universals appear to be tight and no obvious exhaust to body contact with the rear wheels being on ramps.
What else might I check and how can I tell if a muffler is coming apart internally if that might be the source.
Richard
'94 GT 'vert Under Drive Pulleys Transgo HD2 Reprogramming Kit High Stall Torque Converter 4:10 Gears Gripp Sub Frame Connectors (welded) Laser Red
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Remove the driveshaft and check the U-joints.... the reason I say 'remove the driveshaft' is because you can only check for loose joints with it installed.... After the driveshaft is out - inspect ot for missing balance weights (you'll see evidence of a spot weld), dings and the u-joints for play and freedom of movement.
HTH

may
No
of
circumstance
can't
to
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.