1999 F150 Two Problems

Just like to know if these are common problems to the F150? 1. Every so often my windshield wipers will make one sweep, This happens a
couple of times a month. Nothing usual is going on when this happens. 2. Lately, when I turn the ignition on, all my gauges Tach and Speedo included go to the max readings, stay there for a second or too them everything is back to normal. If this an indication of future problems? I never noticed the speedo and tack pegging to the max before. Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just by chance, does it happen when you use your turn signal? Mine does that once in a while.
Spdloader

a
I
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The intermittent wiper issue was repaired under a recall on my 1999 Expedition.

happens
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
So it was on my '99 F350, but not on my '95 Bronco
Spdloader

problems?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks, Ill check to see if there ate any recalls on it.

happens.
Speedo
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
it may have happened with the use of the signal..but it is not necessary. I can be driving straight down a street and then the wipers will make one sweep. Never more than one sweep though.

happens
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The 'Phantom Wiper' is a defective multifunction switch. There was a recall out for it and it is a common problem for it to go bad. Except here in Louisiana where nobody touches the turn signal lever. :-) The gages going to full on startup is most likely a bad battery (or alternator not charging). If the voltage drops below a certain level, the computer will reset and on turn on will sweep the gages.
-- 'Fritz the Cat' Blackburn VP-94 Techrep NAS New Orleans http://www.fritzthecat.info
JGK wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have the same problem with my 99 150 also. The wiper thing amazes me. Of course the question is, will the dealer's cover it under the recall? After all, it has been 4 years.........
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.